Epson Stylus Sx235W Won't Print

Discussion in 'Miscellaneous Hardware' started by AlbertSteptoe, Nov 21, 2012.

  1. AlbertSteptoe

    AlbertSteptoe Registered Members

    Joined:
    Jan 28, 2011
    Messages:
    93
    Location:
    UK
    Was given a (practically) unused Epson Stylus SX235W, but just can't get it to print.

    Once I'd set up and downloaded the drives (there was no disc with it) my computer immediately recognsed it, but it just won't print. I initially had a flashing 'teardrop' icon, but with some messing about and by taking out and replacing the cartridges it settled down and I thought I'd fixed it. But still it won't print.

    I don't get any onscreen error messages or flashing lights on the printer - it just sits there as though I haven't given it a command. If i try to print from MS Word, the print setting page comes up (number of pages, landscape/portrait, etc), but then when I hit print the box disappears and nothing... not even so much as a whir or click.

    However, this particular model has a scanner, and I CAN scan without problems, which suggests there's nothing wron with the ink flow, etc.

    Any ideas? Thanks in adavnce.
     
  2. Ricardo

    Ricardo Registered Members

    Joined:
    Nov 10, 2012
    Messages:
    469
    Location:
    Windsor,Ont,Canada
    Hi Albert, Ricardo here. I have a suggestion for you. Try going to the Epson web site and grab the drivers for your particular model there. Download them, re-boot and see what happens. Sometimes the drivers that Windows apply don't always work and being the fact that you don't have a software disk for your model, this may be your best bet.

    Cheers: Rich :nod:

    Actually, on second thought try this: >>>>>>>> http://esupport.epson-europe.com/ProductHome.aspx?lng=en-GB&data=VkjUmbBFNN0DPcNTs620JFP0DUjWTY4+Ll9cfyVk7PgU003D&tc=6
     
  3. Ricardo

    Ricardo Registered Members

    Joined:
    Nov 10, 2012
    Messages:
    469
    Location:
    Windsor,Ont,Canada
  4. jaylach

    jaylach Registered Members

    Joined:
    Nov 11, 2012
    Messages:
    475
    When you say that you took out and replaced the cartridges do you mean that you put in new cartridges? If not the current cartridges may be dried out.

    More likely than the above is that the rollers that feed the paper are stuck, with a dried cartridge I'd still expect the paper to feed.

    Not guaranteed but since you can scan I doubt that there is a critical problem with your drivers. That said Ricardo has given you a link to your drivers on the Epson site. If that is not where you got the drivers initially I'd make use of the link.

    Ahhh! Last thing. Make sure that you are actually selecting the Epson printer for the print job. Since the printer is recently added the default printer could well be different, could even be set to Microsoft's document writer.
     
  5. AlbertSteptoe

    AlbertSteptoe Registered Members

    Joined:
    Jan 28, 2011
    Messages:
    93
    Location:
    UK
    Thanks for the replies, gents. I'll certainly use those links and download anything it suggests.

    Jaylach, I checked again and It's defaulting to the new Epson so no issue there.

    Another thing I forgot to mention is that I get the same lack of a response when I open up the assistant thing and try to print off a test page / clean heads / clean nozzle.

    Anyway, I shall try the links and see how things go. Thanks again :).

    Rickardo, 'scuse my ignorance, but all those files on the Epson website appear to be .dmg files. When I looked up what these were it turns out they're image files for Mac users.
     
  6. AlbertSteptoe

    AlbertSteptoe Registered Members

    Joined:
    Jan 28, 2011
    Messages:
    93
    Location:
    UK
    Mmm, the plot thickens. I found a software and driver package for the printer and tried to install it. It seemed far more comprehensive that the first driver download I did (far more steps). One of the last steps is a screen asking me if I want to connect via usb or WiFi. It's already connected with a usb so I chose this. After about 5 minutes of waiting it eventualy came up with a message saying it couldn't find my printer. I did the trouble shooting it advised (check cables and that the printer is switched on). They were all fine so I went back a step and tried to connect via WiFi and the same thing happened again - "Can't find printer".

    It doesn't make sense. Whenever I try to print anything I get the print setup screen and can clearly see my printer there in the selection, so that proves my computer recognises it??
     
  7. jaylach

    jaylach Registered Members

    Joined:
    Nov 11, 2012
    Messages:
    475
    Just to throw it out there it has to be accepted that there is always the possibility that there is something wrong with the printer. After all it is not new. Is there any way that you could try to install it on another system?

    I assume that you are downloading drivers for the proper version of Windows...
     
  8. DSTM (Dougie)

    DSTM (Dougie) Retired CHF Staff

    Joined:
    May 3, 2009
    Messages:
    5,807
    Location:
    SYDNEY AUSTRALIA
    I'm still thinking your printer is not set as the default printer in the control panel.
    As was mentioned earlier "Microsoft XPS Document writer" may still be ticked.
    May be an idea to check again.
    Is your printer listed there as an option and has it the Black tick beside it.?
     
  9. AlbertSteptoe

    AlbertSteptoe Registered Members

    Joined:
    Jan 28, 2011
    Messages:
    93
    Location:
    UK
    Jay, yes it's possible the printer is faulty, but according to my sister it's never been used. It was bought for her husband as he wanted a small printer because he travels so much. When they saw the size it was put aside and as uneeded item, so I doubt it's faulty.

    DTSM, checked the control panel and the Epson is listed and ticked. However, while going through a troubleshooter just now and performing a command prompt, I got a yellow bubble in my taskbar that popped up and said:

    If I click the bubble I then get a list of ports (8 in all) with one of them saying "Unknown device"
     
  10. DSTM (Dougie)

    DSTM (Dougie) Retired CHF Staff

    Joined:
    May 3, 2009
    Messages:
    5,807
    Location:
    SYDNEY AUSTRALIA
    You say this printer is brand new and never been used.
    Where is the install cd then?
    Are you sure you did the install for Windows and not a Mac
    From your last post it seems as the drivers are not installed correctly otherwise Windows would recognize the Device.
    Uninstall the drivers in Device manager for the printer and try reinstalling the correct drivers again
    Failing that wait for further advice
     
  11. jaylach

    jaylach Registered Members

    Joined:
    Nov 11, 2012
    Messages:
    475
    To add to what DSTM said if I may... Since the error is coming through USB you can also try uninstalling everything USB in Device Manager and re-boot. This will allow Windows to re-install USB. You probably won't get all the USB as sooner or later you will hit your mouse.

    As to drivers...

    The Epson US site does not list your printer but the Epson UK site does. The following link will take you to the support page for your printer. Make sure to select the proper OS version for your system.
    http://www.epson.co.uk/gb/en/viewcon/corporatesite/products/mainunits/support/11101
     
  12. AlbertSteptoe

    AlbertSteptoe Registered Members

    Joined:
    Jan 28, 2011
    Messages:
    93
    Location:
    UK
    DSTM, no idea where the disc is, she's probably mislaid it somewhere. When I say unused I don't mean it's never been out of its box.

    Jay, I'll have a look at that link, but last time I tried installing the software and drivers it failed during the latter stages when it failed to recognise the printer via usb and WiFi, so I can only imagine the same thing will happen again.

    [Edit] Just checked that link and it's the exact same package I downloaded yesterday - the one that failed to recognise the printer. And yes, I am selecting the correct OS.

    I'll try DSTM advice to uninstall.
     
  13. AlbertSteptoe

    AlbertSteptoe Registered Members

    Joined:
    Jan 28, 2011
    Messages:
    93
    Location:
    UK
    I uninstalled the driver (didn't know which one I was supposed to uninstall so I did the one that said 'Unknown Device' as this was the one that seemed to be creating the problem. I then tried to re-install the software and driver package again and the same thing happened. Reached the part where it ask how I want top connect to the printer (usb or WiFi), but whichever I chose it eventually says, "The product cannot be recognised".

    I've changed the usb cable, so I think we can safely presume the printer IS faulty afterall.

    Thanks for all your help :)
     
  14. Ricardo

    Ricardo Registered Members

    Joined:
    Nov 10, 2012
    Messages:
    469
    Location:
    Windsor,Ont,Canada
    Well Albert, it seems that you have tried all possibilites. I got rid of my ink jet printer as I was tired of buying ink cartridges. I went out and bought a Brother laser printer and I love it.

    Cheers: Rich :up:
     
  15. AlbertSteptoe

    AlbertSteptoe Registered Members

    Joined:
    Jan 28, 2011
    Messages:
    93
    Location:
    UK
    Well this is just baffling beyond words!! At time of writing it is 05:03 and about 30 minutes ago just as I was shutting down the PC prior to going to bed, something told me to try the software and driver installation one more time.

    I tried the installation about three times before this, and everytime it failed at the same hurdle (connecting with the printer, either via usb or WiFi). You can imagine my surprise, then, when this time it worked!

    I sat watching the same screen, waiting for the same message (The device cannot be recognised), when all of a sudden a different result popped up; a huge tick and the message 'The device can be recognised. Please wait...). I waited and it eventually completed the set-up and told me to restart.

    A miracle, I proclaimed! Until I tried to actually print something and discovered it STILL lies there silently, completely failing to recognise my command. It won't do nozzle checks or a head clean, just as before.

    So my computer recognises the printer (it shows up in the print preview and control panel, and IS selected/ticked), and the software and drivers finaly installed succesfully, and yet it STILL won't print???

    NB: I'm not sure if this is relevent, but if I bring up the 'Print Que' after a failed attempt to print, there's nothing in there - which tells me the command isn't even reaching the printer, despite everything prior to this suggesting it's going through the motions just as it should. It's only when it comes to the actual printing process that it seems to hit a problem and won't proceed with the print.

    It might help if I was getting error messages, but I don't even get that.
     
  16. jaylach

    jaylach Registered Members

    Joined:
    Nov 11, 2012
    Messages:
    475
    The failure to see the document in the Print Que is an indication that the document IS in fact getting to the printer. Have you double checked to make sure that the printer is selected as the default. If the printer is set as default un-select it, re-boot and re-select it. If still mo joy, I vote for a faulty printer... or a physical switch on the printer in the wrong position.
     
  17. AlbertSteptoe

    AlbertSteptoe Registered Members

    Joined:
    Jan 28, 2011
    Messages:
    93
    Location:
    UK
    Well as I said in my very last post, the printer IS selected.

    I'll try the unslecting / reslecting thing, but I'm not overly hopeful.

    Thanks.
     
  18. Plastic Nev

    Plastic Nev SUPER MODERATOR Super Moderators

    Joined:
    May 2, 2009
    Messages:
    2,303
    Location:
    In front of a monitor in Blackburn Lanc's UK.
    Hum, at this stage I am not exactly sure as to what will happen. However it strikes me that some installation procedures are or were back to front. For some reason printers tend to not work correctly or refuse, as in this case, to work if plugged in before all software is installed first.

    Normally a new printer should be installed from the disk first, whereupon at some stage of the installation you are prompted to then plug in the USB connection to physically connect it.

    However you are not working from a disk, just downloaded drivers, so before consigning the printer as faulty, go back to the beginning by uninstalling everything so far installed. Remove the USB connection, then reboot and install the driver package again, it may or may not ask for the printer to be plugged in, but if it doesn't, wait till you are sure the drivers are installed, then plug the printer back in.

    Worth a try before sending the printer to the recycle centre or the repair shop.

    Nev.
     
  19. AlbertSteptoe

    AlbertSteptoe Registered Members

    Joined:
    Jan 28, 2011
    Messages:
    93
    Location:
    UK
    Thanks, Plastic, I shall try this right now and get back to you.
     
  20. AlbertSteptoe

    AlbertSteptoe Registered Members

    Joined:
    Jan 28, 2011
    Messages:
    93
    Location:
    UK
    I had high hopes about that one, Nev, just a strange sense that it was going to fix the problem, but alas no.

    Still the same reluctance to do anything when it comes to the actual printing, and still no errors to point me in the right direction.
     

Share This Page